问题现象
ECS实例启动失败或系统服务无法正常运行,例如使用chattr命令修改sshd_config文件时提示Read-only file system ***。
可能原因
该实例的/etc/fstab文件中将根文件系统/配置为只读挂载ro,使系统或进程因无法正常写入文件,导致实例启动失败或系统服务无法正常运行。
解决方案
修改/etc/fstab中文件系统挂载选项
使用VNC方式远程登录ECS实例。
具体操作,请参见连接方式概述ECS远程连接操作指南。
查看挂载选项。
cat /etc/fstab
如下图所示,表示根文件系统
/挂载模式为只读ro,需要将挂载模式修改为可读写rw。
修改挂载模式为可读写
rw。mount -o remount rw /
修改
/etc/fstab文件中根文件系统/挂载模式为可读写rw。打开
/etc/fstab配置文件。vim /etc/fstab
修改根文件系统
/挂载模式为可读写rw。
按Esc键,输入
:wq保存修改。重启实例使修改生效。
reboot

